Technorati Rank WordPress Plugin 2-версиясы чыкты!

Биринчи Technorati Rank Pluginдин таманында ысык, мен аны чыгаруу үчүн мазмунду кайрадан иштеп чыктым CSS айдалган (төмөндө скриншот, сиз менин сайтымдын каптал тилкесиндеги сүрөт менен иштеше аласыз):

Technorati Rank WordPress плагининин 2 -версиясы

Бул аны өндүрүү бир аз татаал болгон, бирок чыгарылышы бир кыйла жагымдуу. Биринчиден, мен үйрөнгөн нерселеримди пайдаландым Bittbox Сүрөттөгү чыгуучу баскычтардын ар бирин Illustrator программасында жасоо.

Кийинки кадам чындыгында бирөөнү куруу үчүн стилдерди колдонуу болду сүрөт картасы Чындыгында гана бар карта жок! Чындыгында, бул абдан сонун. Жалпы div фонун орнотуп, андан кийин абсолюттук жайгаштырууну жана CSSти колдонуп, "очоктордун" ар бирин түзсөңүз болот. CSS чыгарылышын көрүү.

Мен дагы Technorati компаниясынын жаңы шилтемесин коштум WTF баракчасы жана сайттын RSS дареги. Сизге жагат деп ишенем! Менин оюмча, бул биринчи версиясынан кыйла кеңейтилген! Бар i плагинди жайылтуучу оң жактагы шилтеме.

Учурдагы Technorati Rank WordPress Plugin Version 2.0.4

23 Comments

  1. 1
    • 2

      Албетте! Мен бир топ убакыттан бери Illustratorдон жардам издеп жүргөм. Мен муну фантастикалык кылуу үчүн жетиштүү деңгээлде колдоно албайм, андыктан Bittbox сыяктуу сайт мага көп убакытты үнөмдөйт!

  2. 3

    Сиздин "катка" берген көрсөтмөлөрүңүз боюнча эң жаңы жана эң улуусун орнотууга аракет кылдым 🙂

    бирок мен төмөнкү катаны алдым

    Өлүмгө алып келген ката: Жок болгон классты орнотуу мүмкүн эмес: 4-сапта simplexmlelement /home/winex64/public_html/wp-content/plugins/technorati-rank/technorati-rank.php

    сунуштар барбы?

    • 4
      • 5
        • 6

          Мен ишенем! Бирок сиздин хостуңуз жаңырат деп ишенем. PHP5 чындыгында иштин жакшырышын, ошондой эле API'лерди керектөө үчүн мыкты шаймандарды алып келет. Мен Jumpline программасын колдоном, демөөрчүлөр тизмесиндеги шилтемени менин үй баракчамдан көрө аласыз. Ошондой эле, Dotsterдин эң мыкты жана мыкты деп саналган VDS хостингине ээ экенине ишенем.

      • 7

        Даг,
        Менде деле ушундай көйгөй бар
        Мен хостума чалдым, алар менин серверимде PHP 4 жана PHP 5 бар деди, бирок мен PHP 5 колдонуп файл иштетсем, скриптте .php5 файл кеңейтүүсү болушу керек.

        Ошентип ... Мен файл кеңейтүүлөрүн өзгөрттүм, ал WordPress плагиндеринде жок болуп калат.

        Идеяңыз барбы?

  3. 10

    Awesome Plugin, Мыкты стилдөө! Рахмат Даг, жана сонун иш. Биринчиси жөнүндө эч качан билген эмесмин, бирок бул менин каптал тилкесимде болуп жатат.

    Менин Illustrator кеңештерим сиздин баскычтарыңызды жасоого жардам бергендигин көрүү чындыгында эле сыйлык болуп саналат !!!!!

    дагы бир жолу рахмат,

    ~ BittBox

    • 11

      Ырахмат, BittBox! Менин оюмча, мен стилди жакшы байкадым, бирок көпчүлүк учурда аны эч качан туура таба албайм. Сиздин үлгүлөрүңүздү чындыгында жүктөп алып, аларды бөлүп алуу мүмкүнчүлүгү эмне менен айырмаланат. Мен азыр ошол идеяларды ишке ашыра алам. 🙂

      Блогумдун башы жана кийинки тектери жөнүндө ойлонуп жатам.

  4. 12

    Даг, 2-версиядагы плагин мени жек көрөт окшойт. Мен ката жөнүндө билдирүүлөрдү алам:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Ката жөнүндө билдирүүлөргө карабастан, ал менин Technorati даражамды көрсөтөт (~ 26.5k: D). PHP эмне үчүн ошол бир файлдын үстүнөн ыйлап жаткандыгын билүү үчүн жетиштүү деңгээлде маалыматым жок.
    Эң кызыгы, биздин серверде биз SuPHPди колдонобуз, ошондуктан бардыгы бизде иштейт (андыктан chmod талаптары дүйнөгө жазыла турган файлдарды талап кылбай калат, мисалы, chmod' өтө эле жогору болсо, php скрипттери аткарылбайт).

    Бул субдомендин бардык phpлери php5 катары иштейт.

    Жокпу?

    • 13

      Сизде Xial wp-content / cache каталогу барбы? WP-Cache сыяктуу эле кэш каталогун колдонсоңуз жакшы болмок деп ойлодум. Артка кылчайып карасам, балким, бул жакшы идея болгон жок! Бул сап сөзсүз түрдө кэш файлына жазылат.

      • 14

        Мен, албетте, Даг. Мен бир топ убакыттан бери WP-Cache иштетип келе жатам. 🙂

        Эмне үчүн бул боюнча нааразычылыгын билдиргенине кызыгып көрдүм, анткени менде керектүү каталог бар, бирок ал таптакыр башка нерсе деп божомолдоп жатам.

      • 15

        Кошуу үчүн кызыктуу маалымат:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Ал дагы деле каталарды кайтарып берет.

    • 16

      Жөн гана ошол эле ката бар деп коёлу. Сайт php5 иштетип, баскычы көрсөтүлөт.
      121-123 саптарын комментарийлеп көрдүм, сайгыч жакшы иштейт. Түз эфирге койсом болобу, же ошол сызыктардын жоктугу узак мөөнөттө кыйынчылык жаратабы?

  5. 17

    Жогорудагыдай эле каталар кетип жатат, мен муну менин кэш дир деп ойлогом, бирок менде ошондой эле, ошондой эле жазуу укуктарынын туура экенине ынандым.
    Каптал тилкесинде ал плагинди көрсөтөт (ранг менен), бирок жогорудагы каталар менен.

    • 18

      Салам Ричард,

      Сизде PHP 5+ версиясы бар экендигин жана CURL иштетилгенин текшере аласызбы? Муну сиз өзүңүздүн сайтыңызга баракча куруу аркылуу жасай аласыз <?php phpinfo(); ?> бир баракта. Андан кийин ошол баракчаны ачыңыз. Беттин жогору жагында сиздин PHP версияңыз болот жана аны иштетүү үчүн CURL деп издесеңиз болот.

      Рахмат!
      Даг

      • 19

        Даг, мен PHP версиямды эки жолу текшердим.
        Мен PHP5 иштетип жатам, жана cURL (PHPге топтолгон нерселер жөнүндө хостума болгон үч суранычымдын бири) камтылган.

        Калгандарынын бардыгы жакшы иштейт, бирок бул плагиндин эмне үчүн тумчугуп жатканына толук ишенбейм, эгер PHPде cURLдин версиясы болбосо (биз 7.15.4, эң акыркы 7.16.1 окшойт). Бирок, мен жардам бере алсам, хостумду php5ти дагы бир жолу топтогум келип жатат. <: 3

        • 20

          Ушул дем алыш күндөрү тереңирээк көз чаптырам. Ал бир нече сайтта көйгөйсүз иштеп жатат - демек, бул 3 нерсенин бири: 1. Кэш, 2. cURL же 3. PHP Версиясы.

          Эски PHP 4 функциясын колдонуп, XMLди таркатып, талдай алам, бирок аны бир аз басаңдатышы мүмкүн - ушул дем алыш күндөрү сынап көрөйүн деп жатам. Бардык салымдарды баалайм. "Houston, бизде көйгөй бар!".

  6. 21

    Жөн гана эскертүү: Technorati анды ишке киргизди бийлик Плагин.

    Ошондой эле - бул плагинге байланыштуу көйгөйлөргө туш болгондордун бардыгы үчүн, мен сизди жаңы хостко өтүүгө үндөйт элем :). Мен өзүмдүн түбүмдө хост менен 12 айлык акысыз атайын белек алдым жөнүндө бет.

  7. 22

    Салам Даг,

    Плагин боюнча мыкты иш. Бул Jumpline'де "кутудан тышкары" иштеп, эми менин блогумда орнотулган.

  8. 23

    Кэш файлынан жазууда же окууда каталар болду деген бир нече өтүнүчтү алдым. Мен чындыгында кэш файлын түпкү каталогго түртүп жана тартып жаткан жеримде көйгөй аныкталды. Мен 2.0.4 версиясын плагинин каталогундагы кэш подкаталогуна жазуусу үчүн өзгөрттүм.

    Сураныч, анын кандай иштээрин мага кабарлап коюңуз! (Дагы эле SimpleXML жана cURL керек!)

Эмне деп ойлойсуң?

Бул сайт спам азайтуу Akismet колдонот. Сиздин комментарий маалымат кандайча иштелишин Үйрөнүү.